Mixed Content error in Chrome console

6 Replies ·

  1. Hello,

    I am having trouble trying to track down this mixed content error (displayed in my Chrome browser console). The error occurs on every page/post.

    I have checked my functions.php file but its fine.

    Could this be caused by JetPack’s Custom CSS module?

    Any ideas where this strict path is originating from so that I can change it to a relative path?

    ******************************************
    Mixed Content: The page at 'https://tibesar.com/start-here/' was loaded over HTTPS, but requested an insecure stylesheet 'http://tibesar.com/wp-content/themes/stargazer/style.css?ver=2.9.9.1'. This request has been blocked; the content must be served over HTTPS.
    ******************************************
    Thank you very much!

    Marcus
    tibesar.com

  2. Marcus Tibesar

    Mixed Content: The page at 'https://tibesar.com/2015/06/14/laura-tibesar-rencher-celebrates-her-48th-with-family/' was loaded over HTTPS, but requested an insecure stylesheet 'http://tibesar.com/wp-content/themes/stargazer/style.css?ver=2.9.9.1'. This request has been blocked; the content must be served over HTTPS.

  3. Justin Tadlock

    Are you running your site with SSL? You’ll probably need an SSL plugin to handle converting all the `http:` calls to `https:` such as with stylesheets.

  4. Marcus Tibesar

    Hello Justin.

    Yes, I have been running SSL for years now and (finally) decided to get it all converted to https.

    I replaced the General Settings (WordPress Address URL and Site Address URL) to reflect https://tibesar.com (vs. http://tibesar.com).

    This change fixed all but one of the red mixed content errors.

    To fix all the yellow mixed content errors, I used the Search Regex plugin and replaced all the http://tibesar.com media links in the Posts to https://tibesar.com (over 3,500 links that took seconds to search and replace).

    I fixed a strict http path within the functions.php replacing it with a relative path.

    Now, I only have one more red mixed content error to hunt down and adjust. It occurs on all Pages and Posts so I’m thinking its origin could be a plugin or possibly css.

    The full http path name is calling the stargazer theme css so was hoping this was something obvious.

    I was hoping to not have to install another plugin since I have made super progress in getting the site 99% https.

    Is there another way of identifying the origin of this perhaps?

    Thank you so much!

    Marcus Tibesar
    Tibesar Family Archives

  5. Justin Tadlock

    Now that I’m looking at it a little more closely, I’m seeing this in your header:

    ` `

    This is actually not coming from the theme. It looks like the WP Members (This plugin?) is loading the stylesheet. That’s something that should be fixed in the plugin.

  6. Marcus Tibesar

    Holy cow Justin! Great eye!

    I’ve been looking for the origin all day obviously to no avail.

    You nailed it! WP-Members is the plugin I use for managing memberships to the private site.

    I checked the WP-Members settings and wala there it was. Several years ago when I first configured this plugin I used a http path.

    There are now no mixed-content errors and the site is 100% https.

    Now the hard part is to keep it that way.

    Can’t thank you enough for identifying the true source!

    Thank you Justin.

    Marc

  7. Marcus Tibesar

    Holy cow Justin! Great eye!

    I’ve been looking for the origin all day obviously to no avail.

    You nailed it! WP-Members is the plugin I use for managing memberships to the private site.

    I checked the WP-Members settings and wala there it was. Several years ago when I first configured this plugin I used a http path.

    There are now no mixed-content errors and the site is 100% https.

    Now the hard part is to keep it that way.

    Can’t thank you enough for identifying the true source!

    Thank you Justin.

    Marc