Membership expired all of a sudden?

Over the weekend, a bug was fixed on the Theme Hybrid support forums. The problem was that some users had access to the support forums but were asked to renew their membership if they tried to log into the main site. The bug allowed users with expired memberships access to the support forums. The bug was fixed this weekend.

Therefore, if your access to the support forums is suddenly blocked, it just means your membership has already expired (Theme Hybrid memberships are for one year). You can renew your membership for an additional year by visiting the club page.

Sorry for the inconvenience (though I’m sure some of you enjoyed the few extra months of free forums access). I just wanted to let everyone know what was happening.

If you run into any trouble, just shoot me an email via the contact form.

10 Comments


  1. Theme Club page still has the bug. It still shows one as an exclusive member and does not show any link to renew the membership.

  2. Slipn

    I cannot get anywhere to renew. Logged out and in several times.

    All I can get to is a signup page but I don’t want to lose all my favorite and saved topics.

    Where can I find an actual renew link? Not just a sign up link.

  3. Slipn

    Never mind I used the slider “open” up at top and found the renew link by logging in there

  4. CECat

    This issue still appears not to be resolved. I’ve logged in and out mulitple times to no avail. No renewal link to be found anywhere. In addition, I used the contact form to send a message a week to ten days ago, and have had no response to that, either.

  5. Ploobers

    I have the same issue as well. I’d like to renew my membership, but there’s no link to do so.


  6. it’s okay here. No problem anything here. I have renewed and this is good :)


  7. @Everyone

    Sorry about the issues. I’ve been working with the users who emailed me to figure this out. You should be able to renew/upgrade your membership from the club page now.

  8. suhayse

    So, has anyone with an up-to-date membership complained about still not having access to the forums after they’ve logged in? This is my situation.

Comments are closed.